]> www.infradead.org Git - users/dwmw2/openwrt.git/commitdiff
ramips: mt7621: tidy up names for Ubiquiti devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 7 Apr 2020 08:47:18 +0000 (10:47 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 12 Apr 2020 11:25:42 +0000 (13:25 +0200)
The "proper" vendor prefix for Ubiquiti is "ubnt", this is used in
all targets except ramips and also recommended by the kernel.

This patch adjusts the various board/image/device name variables
accordingly. Since we touch it anyway, this also adds the space
in "EdgeRouter X" as a hyphen to those variables to really make
them consistent with the model name.

While at it, create a real shared definition for the devices in
image/mt7621.mk instead of deriving one device from another.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx-sfp.dts [deleted file]
target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx.dts [deleted file]
target/linux/ramips/dts/mt7621_ubnt_edgerouter-x-sfp.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_ubnt_edgerouter-x.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_ubnt_edgerouter-x.dtsi [moved from target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx.dtsi with 100% similarity]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
target/linux/ramips/mt7621/base-files/lib/preinit/07_mt7621_bringup_dsa_master
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh

diff --git a/target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx-sfp.dts b/target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx-sfp.dts
deleted file mode 100644 (file)
index b4deb49..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-/dts-v1/;
-
-#include "mt7621_ubiquiti_edgerouterx.dtsi"
-
-/ {
-       model = "UBNT-ERX-SFP";
-       compatible = "ubiquiti,edgerouterx-sfp", "mediatek,mt7621-soc";
-};
-
-&i2c {
-       status = "okay";
-
-       pca9555@25 {
-               compatible = "nxp,pca9555";
-               reg = <0x25>;
-       };
-};
diff --git a/target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx.dts b/target/linux/ramips/dts/mt7621_ubiquiti_edgerouterx.dts
deleted file mode 100644 (file)
index 5c1d9ec..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-/dts-v1/;
-
-#include "mt7621_ubiquiti_edgerouterx.dtsi"
-
-/ {
-       model = "UBNT-ERX";
-       compatible = "ubiquiti,edgerouterx", "mediatek,mt7621-soc";
-};
diff --git a/target/linux/ramips/dts/mt7621_ubnt_edgerouter-x-sfp.dts b/target/linux/ramips/dts/mt7621_ubnt_edgerouter-x-sfp.dts
new file mode 100644 (file)
index 0000000..9515f1d
--- /dev/null
@@ -0,0 +1,17 @@
+/dts-v1/;
+
+#include "mt7621_ubnt_edgerouter-x.dtsi"
+
+/ {
+       model = "Ubiquiti EdgeRouter X SFP";
+       compatible = "ubnt,edgerouter-x-sfp", "mediatek,mt7621-soc";
+};
+
+&i2c {
+       status = "okay";
+
+       pca9555@25 {
+               compatible = "nxp,pca9555";
+               reg = <0x25>;
+       };
+};
diff --git a/target/linux/ramips/dts/mt7621_ubnt_edgerouter-x.dts b/target/linux/ramips/dts/mt7621_ubnt_edgerouter-x.dts
new file mode 100644 (file)
index 0000000..260baf9
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+#include "mt7621_ubnt_edgerouter-x.dtsi"
+
+/ {
+       model = "Ubiquiti EdgeRouter X";
+       compatible = "ubnt,edgerouter-x", "mediatek,mt7621-soc";
+};
index 6b2e68b03b18d50bc349e788fe1ea4c47242a188..806286b0bb5cef39334b32c358a976c67f11d3d1 100644 (file)
@@ -794,27 +794,30 @@ define Device/tplink_re650-v1
 endef
 TARGET_DEVICES += tplink_re650-v1
 
-define Device/ubiquiti_edgerouterx
+define Device/ubnt_edgerouter_common
+  DEVICE_VENDOR := Ubiquiti
   IMAGE_SIZE := 256768k
   FILESYSTEMS := squashfs
   KERNEL_SIZE := 3145728
   KERNEL_INITRAMFS := $$(KERNEL) | \
        ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-  DEVICE_VENDOR := Ubiquiti
+endef
+
+define Device/ubnt_edgerouter-x
+  $(Device/ubnt_edgerouter_common)
   DEVICE_MODEL := EdgeRouter X
-  SUPPORTED_DEVICES += ubnt-erx
+  SUPPORTED_DEVICES += ubnt-erx ubiquiti,edgerouterx
 endef
-TARGET_DEVICES += ubiquiti_edgerouterx
+TARGET_DEVICES += ubnt_edgerouter-x
 
-define Device/ubiquiti_edgerouterx-sfp
-  $(Device/ubiquiti_edgerouterx)
-  DEVICE_VENDOR := Ubiquiti
-  DEVICE_MODEL := EdgeRouter X-SFP
+define Device/ubnt_edgerouter-x-sfp
+  $(Device/ubnt_edgerouter_common)
+  DEVICE_MODEL := EdgeRouter X SFP
   DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x
-  SUPPORTED_DEVICES += ubnt-erx-sfp
+  SUPPORTED_DEVICES += ubnt-erx-sfp ubiquiti,edgerouterx-sfp
 endef
-TARGET_DEVICES += ubiquiti_edgerouterx-sfp
+TARGET_DEVICES += ubnt_edgerouter-x-sfp
 
 define Device/ubnt_unifi-nanohd
   DEVICE_VENDOR := Ubiquiti
index f573a049ce7128d74366400800d7cf882f4375f8..252f9f1dda6c426007d5e411991f8a51f4e4c481 100755 (executable)
@@ -42,8 +42,8 @@ ramips_setup_interfaces()
        mikrotik,routerboard-750gr3)
                ucidef_set_interfaces_lan_wan "lan2 lan3 lan4 lan5" "wan"
                ;;
-       ubiquiti,edgerouterx|\
-       ubiquiti,edgerouterx-sfp)
+       ubnt,edgerouter-x|\
+       ubnt,edgerouter-x-sfp)
                ucidef_set_interface_lan "eth0 eth1 eth2 eth3 eth4"
                ;;
        *)
index 511d9deed8f195bda2bfe79eabe2e4f90c3c877a..91a9459d8c86f1c06c4976361ed54a25d725edbf 100755 (executable)
@@ -13,10 +13,10 @@ mikrotik,routerboard-750gr3)
 telco-electronics,x1)
        ucidef_add_gpio_switch "modem_reset" "Modem Reset" "16"
        ;;
-ubiquiti,edgerouterx)
+ubnt,edgerouter-x)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "0"
        ;;
-ubiquiti,edgerouterx-sfp)
+ubnt,edgerouter-x-sfp)
        ucidef_add_gpio_switch "poe_power_port0" "PoE Power Port0" "496"
        ucidef_add_gpio_switch "poe_power_port1" "PoE Power Port1" "497"
        ucidef_add_gpio_switch "poe_power_port2" "PoE Power Port2" "498"
index 7a112521685b80c7d51d238c8dfd36afbff00c52..b8ebcc3f41bfa6b05bd9a1f0c902c33ca663796f 100644 (file)
@@ -7,8 +7,8 @@ mt7621_bringup_dsa_master() {
     local masterif
 
     case "$board" in
-    ubiquiti,edgerouterx|\
-       ubiquiti,edgerouterx-sfp)
+    ubnt,edgerouter-x|\
+    ubnt,edgerouter-x-sfp)
         masterif="dsa"
         ;;
     *)
index 3f292a5dac968615aafddb15815065bf6da55cc5..864c59c8e5a4cbc0583760dbb900b222f000e5b9 100755 (executable)
@@ -62,8 +62,8 @@ platform_do_upgrade() {
                iodata_mstc_upgrade_prepare
                nand_do_upgrade "$1"
                ;;
-       ubiquiti,edgerouterx|\
-       ubiquiti,edgerouterx-sfp)
+       ubnt,edgerouter-x|\
+       ubnt,edgerouter-x-sfp)
                platform_upgrade_ubnt_erx "$1"
                ;;
        *)